We are continuing to verify the maintenance items.
Posted Jul 02, 2026 - 00:33 AEST
Verifying
Verification is currently underway for the maintenance items.
Posted Jul 01, 2026 - 23:59 AEST
Update
Started the Deployment process
Posted Jul 01, 2026 - 23:00 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2026 - 23:00 AEST
Scheduled
A new patch will be deployed tonight at 23:00 AEST. This patch will include following fixes/new features:
- [Story] Enhanced Crew Connection View - [Story] COBT - Bars are not showing when view is active - [Story] Revert Ops Spares from asr-ds so other code can be loaded to dev - [Story] ASR>OC rebranding - Promote GUI and WEBUI changes to all environments - [Story] Rule Matching Logic for Auto‑Selecting Saleable Config - [Story] Dynamic Constraints - Reference Pax Figures - Ensure rule is triggered - [Story] Create crew warning on aircraft swap resulting in aircraft type change - [Enabler] SLOTCO Contract-based testing - create the log groups for contract testing - [Story] Dynamic Constraints - Reference Pax Figures - Attribute in admin portal - [Story] Removal of any source ingress rule from Schedule-recovery-workers cluster and replacing it with 1A IP range and QF in DEV, UAT, Staging and PRD - [PTR] asr-solver EB environment PROD deployment failure due to Elastic Load Balancer inbound rule misconfiguration - [PTR] Fix the known bug in the asr-gui-log-processor--processGuiLog lambda code that prevents a significant number of log lines from being streamed to CloudWatch - [Spike] Cloudwatch logs: Analyse ingested logs and drop the unnecessary high-frequency logs - [PTR] Production CloudWatch Logs Not Streaming for CompassToOgs Integration Since June 7
Please note that: * Slot optimization on all TMIs will be stopped and restarted after the patch deployment. * All frozen slots data will be maintained as it was before patch deployment.
Once the patch is deployed, users have to update their UI, * either by checking from Help -> Check for Updates and accepting the updates and finally restarting the UI. * or, by restarting COMPASS and then accepting the update notification.
Posted Jul 01, 2026 - 20:16 AEST
This scheduled maintenance affected: OC API, AsA Metron Interface, and OGS Interface.