Verification is currently underway for the maintenance items.
Posted Sep 10, 2026 - 23:39 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 10, 2026 - 23:16 AEST
Scheduled
A new patch will be deployed tonight at 23:00 AEST. This patch will include following patches:
- Reintroduce Welcome Screen - Revert Open Program Related Changes - Remove Airline Branding from the Swim Lane - Add Logging in the Search Window
Once the patch is deployed, users have to update their UI, * either by checking from Help -> Check for Updates and accepting the updates and finally restarting the UI. * or, by restarting COMPASS and then accepting the update notification.